RESOLVED
Posted about 2 months ago. 1:16 PM on August 16, 2024
INVESTIGATING
Component impacted: Homepage (japan)